github的升级和hexo的坑

出现这个问题的原因似乎是11月3日下午Github Pages升级了Jekyll,导致了next主题下source/vendors路径下的部分js和css无法访问。

根据next作者的提示 @iissnan https://github.com/iissnan/hexo-theme-next,解决方法如下:

其实就是重命名一下下面的链接:

首先修改source/vendors为source/lib,然后修改_config.yml,将 _internal: vendors修改为_internal:lib

修改:
hexo\themes\next\bower.json 。

参考链接:https://www.zhihu.com/question/52272170/answer/